We are currently experiencing degraded performance due to AWS outage

Incident Report for Rep AI Status

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:34 EDT

Monitoring

AWS has fixed the issue and we are now monitoring.
Posted Oct 20, 2025 - 15:56 EDT

Update

We are monitoring AWS status on the situation.
Posted Oct 20, 2025 - 12:40 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 20, 2025 - 12:39 EDT
This incident affected: Rep AI Admin Console (Rep Admin Console - UI, Insights, Analytics), Rep AI Chat (Rep Chat Widget), and Rep AI - Product Finder.