Slowness in Product Finder Queries

Incident Report for Rep AI Status

Resolved

This incident has been resolved.
Posted May 25, 2025 - 06:30 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 24, 2025 - 11:03 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 23, 2025 - 18:37 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted May 23, 2025 - 18:35 EDT

Update

We have found the issue which affects several stores. We are working on a solution.
Posted May 23, 2025 - 18:34 EDT

Update

We are experiencing problems with getting responses from OpenAI's embedding service which causes the Product Finder service to respond slow
Posted May 23, 2025 - 15:30 EDT

Update

We are continuing to investigate this issue.
Posted May 23, 2025 - 15:25 EDT

Update

We are continuing to investigate this issue.
Posted May 23, 2025 - 14:45 EDT

Investigating

We are currently investigating this issue.
Posted May 23, 2025 - 14:45 EDT
This incident affected: Rep AI Chat (Rep Chat Widget, Connection with OpenAI) and Rep AI - Product Finder.