We are currently experiencing degregated performance due to an AWS outage

Incident Report for Rep AI Status

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 09:35 EDT

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 09:34 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 09:29 EDT

Identified

We are monitoring the situation with the AWS status page
Posted Oct 20, 2025 - 08:12 EDT
This incident affected: Rep AI Admin Console (Rep Admin Console - UI, Insights, Analytics, Catalog real-time sync), Rep AI Chat (Rep Chat Widget, Connection with OpenAI, Gen AI service), and Rep AI - Product Finder.